Accueil Ti-Gen Foire Aux Questions Chat sur le chan #tigcc sur IRC
Liste des membres Rechercher Aide
Bienvenue Invité !   Se connecter             Mes sujets   
Administrer
0 membre(s) et 1 visiteur(s) actif(s) durant les 5 dernières minutes Utilisateurs actifs : Aucun membre + 1 visiteur
Avant de poster sur le forum, il y a des régles de bases à respecter pour une bonne entente et un respect de tous.
Veuillez lire la charte du forum.
  :: Index » GFA-Basic TI68K » Programmation » la fonction poke, petit soucis en gfa (1 réponse(s))
./POST DE DEPART (post n°0)   Marquer comme non lu.
Invité Ecrit le: Lundi 13 septembre 2010 à 11:27 Déconnecté(e)    
 
Je veux faire de la synthèses sonore sur gfa sur atari st,
je connais bien déjà les fonction sound et wave mais il ya juste un problème, j'aimerais être en multitache(autrement la muusique joue et pendant ce temps là le programme tourne comme ci rien été !)
je me suis donc un peu attaquer au langage machine(assembleur) , cela tombe bien on peut le faire en GFA : avec des poke mais aussi le xbios(32)
J'ai voulu commencer avec un poke juste pour changer le volume
voici mes deux lignes
poke FF8800,8 (FF8800 est l'adresse du son, 8 le registre qui gère le volume)
poke FF8802,0 (FF8802 est l'adresse pour mettre l'information, j'ai mis un volume 0, oui c'est juste un test je suis prudent avec les pokes)
Problème les deux lignes passent pas j'ai un reboot du system et deux bombes en dessin qui s'affiche sur le bureau d'accueil de l'atari impossible ensuite de recharger le gFa
J'ai donc vérifie mes adresses mémoires (plusieurs documents convergent bien vers le FF8800 pour le son sur atari st)
j'ai changer un peu en mettant h88FF00 pour bien montrer à l'atari que c'est de l'hexadécimale mais rien çà faire
Je vous remercie d'avance de votre réponse.
patrick28

    
./Post n°1   Marquer comme non lu.
Kevin Kofler Ecrit le: Mardi 14 septembre 2010 à 01:56 Déconnecté(e)    Voir le profil de Kevin Kofler Envoyer un email à Kevin Kofler Visiter le site WEB de Kevin Kofler Envoyer un message privé à Kevin Kofler  


Hmmm, ici c'est un forum pour un "portage" (plutôt une réécriture) de GFA sur calculatrices TI, pas pour la version originale sur Atari.
Membre de l'équipe de TIGCC: http://tigcc.ticalc.org
Mainteneur du portage Linux/Unix de TIGCC: http://tigcc.ticalc.org/linux/
Membre de l'équipe de CalcForge: http://www.calcforge.org:70/

Participez à la reprise de Ti-Gen!
    
  :: Index » GFA-Basic TI68K » Programmation » la fonction poke, petit soucis en gfa (1 réponse(s))
Pages : 1/1     « [1] » »|

.Répondre à ce sujet
Les boutons de code
[B]old[I]talic[U]nderline[S]trikethrough[L]ine Flip Hori[Z]ontallyFlip [V]erticallySha[D]ow[G]low[S]poilerCode [G][C]ite
Bullet [L]istList Item [K] Link [H][E]mail[P]icture SmileysHelp
Couleurs :
Saisissez votre message
Activer les smileys
     

Forum de Ti-Gen v3.0 Copyright ©2004 by Geoffrey ANNEHEIM
Webmaster: Kevin KOFLER, Content Admins: list, Server Admins: Tyler CASSIDY and Kevin KOFLER, DNS Admin: squalyl
Page générée en 169.13ms avec 19 requetes