Accueil Ti-Gen Foire Aux Questions Chat sur le chan #tigcc sur IRC
Liste des membres Rechercher Aide
Bienvenue Invité !   Se connecter             Mes sujets   
Administrer
0 membre(s) et 1 visiteur(s) actif(s) durant les 5 dernières minutes Utilisateurs actifs : Aucun membre + 1 visiteur
Avant de poster sur le forum, il y a des régles de bases à respecter pour une bonne entente et un respect de tous.
Veuillez lire la charte du forum.
  :: Index » Forum PC » Logiciels Linux/BSD » TIGCC (11 réponse(s))
./POST DE DEPART (post n°0)   Marquer comme non lu.
Invité Ecrit le: Samedi 16 octobre 2004 à 19:08 Déconnecté(e)    
 
Y-a-t-il une interface graphique pour TIGCC sous Linux ?
L'invite de commandes ne me gêne pas, mais c'est beaucoup plus pratique de développer avec une interface graphique ! :)
J'ai vu qu'il y avait KTIGCC ?
    
./Post n°1   Marquer comme non lu.
squale92 Ecrit le: Samedi 16 octobre 2004 à 19:19 Déconnecté(e)    Voir le profil de squale92 Envoyer un email à squale92 Visiter le site WEB de squale92 Envoyer un message privé à squale92  

KTIGCC n'est pas fini, loin de là, il me semble

pour coder... bah, ne serait-ce que kate fait très bien l'affaire, avec coloration syntaxique
sinon, tu peux utiliser kdevelop, avec l'auto-completion et les code-hint...

pour ce qui est de compiler, tu te fait un petit shell-script en ligne de commande, qui appelle tigcc pour chacun de tes fichiers sources, c pas vraiment difficile :)
ou alors, tu fais un makefile (parait que c pas dur, mais faut connaitre la syntaxe des makefiles, par contre)
Pascal MARTIN
http://www.squalenet.net
    
./Post n°2   Marquer comme non lu.
Invité Ecrit le: Dimanche 17 octobre 2004 à 13:24 Déconnecté(e)    
 
Ouais, ok. Merci.
    
./Post n°3   Marquer comme non lu.
squale92 Ecrit le: Dimanche 17 octobre 2004 à 19:14 Déconnecté(e)    Voir le profil de squale92 Envoyer un email à squale92 Visiter le site WEB de squale92 Envoyer un message privé à squale92  

pas de pb :)
Pascal MARTIN
http://www.squalenet.net
    
./Post n°4   Marquer comme non lu.
Invité Ecrit le: Dimanche 12 décembre 2004 à 16:28 Déconnecté(e)    
 
Je me suis fait un petit script shell :
tigcc_compiling.sh
#!/bin/sh

echo "Chemin absolu vers TIGCC :"
read path
export TIGCC=$path
echo "Fichier à compiler :"
read fichier

cd $path/bin
./tigcc -O2 $fichier

-Edité le Dimanche 12 décembre 2004 à 16:28 par AS-
    
./Post n°5   Marquer comme non lu.
Kevin Kofler Ecrit le: Dimanche 12 décembre 2004 à 17:55 Déconnecté(e)    Voir le profil de Kevin Kofler Envoyer un email à Kevin Kofler Visiter le site WEB de Kevin Kofler Envoyer un message privé à Kevin Kofler  


AS :
Je me suis fait un petit script shell :
tigcc_compiling.sh
#!/bin/sh

echo "Chemin absolu vers TIGCC :"
read path
export TIGCC=$path
echo "Fichier à compiler :"
read fichier

cd $path/bin
./tigcc -O2 $fichier

Si tu as besoin de ce script, c'est que tu n'as pas installé TIGCC correctement!
La procédure d'installation règle les variables d'environnement pour qu'il suffise de faire:
tigcc -O2 tonfichier
Aucun répertoire à spécifier, rien.

Et au passage, le règlage d'optimisation conseillé est -Os, pas -O2. Et tu as oublié toutes les optimisations du linker. Tu devrais mettre au minimum ça:
tigcc -Os -fomit-frame-pointer -ffunction-sections -fdata-sections --optimize-code --cut-ranges --reorder-sections --merge-constants --remove-unused tonfichier.c
-Edité le Dimanche 12 décembre 2004 à 17:57 par Kevin Kofler-
Membre de l'équipe de TIGCC: http://tigcc.ticalc.org
Mainteneur du portage Linux/Unix de TIGCC: http://tigcc.ticalc.org/linux/
Membre de l'équipe de CalcForge: http://www.calcforge.org:70/

Participez à la reprise de Ti-Gen!
    
./Post n°6   Marquer comme non lu.
Invité Ecrit le: Dimanche 12 décembre 2004 à 18:00 Déconnecté(e)    
 
Ah oui, pas vu. C'est bon j'ai mis les options.
Par contre j'ai installé correctement la "version *nix" et aucun problème. Mais je vais dans le dossier bin pour faire ./tigcc ....
    
./Post n°7   Marquer comme non lu.
Kevin Kofler Ecrit le: Dimanche 12 décembre 2004 à 18:08 Déconnecté(e)    Voir le profil de Kevin Kofler Envoyer un email à Kevin Kofler Visiter le site WEB de Kevin Kofler Envoyer un message privé à Kevin Kofler  


Bah, pas besoin de faire ça, ni de rerègler $TIGCC dans ton script!
La variable $PATH (dont tu abuses d'ailleurs dans ton script, c'est une variable d'environnement système!), règlée globalement lors de l'installation, sert à ça: le shell trouve TIGCC sans que tu ais à te placer dans le répertoire $TIGCC/bin. Et la variable $TIGCC est aussi règlée globalement. Si ça ne marche pas chez toi, c'est que tu n'as pas fait l'installation correctement. Pour corriger ce problème, lance:
TIGCC=/usr/local/tigcc $TIGCC/bin/envreg
(remplace /usr/local/tigcc par le bon répertoire).
Membre de l'équipe de TIGCC: http://tigcc.ticalc.org
Mainteneur du portage Linux/Unix de TIGCC: http://tigcc.ticalc.org/linux/
Membre de l'équipe de CalcForge: http://www.calcforge.org:70/

Participez à la reprise de Ti-Gen!
    
./Post n°8   Marquer comme non lu.
Invité Ecrit le: Dimanche 12 décembre 2004 à 18:39 Déconnecté(e)    
 
Quoi que je fasse j'ai error: $TIGCC not set.
Bon j'installe tigcc-0.95r3-1.i386.rpm.
-Edité le Dimanche 12 décembre 2004 à 18:41 par AS-
    
./Post n°9   Marquer comme non lu.
Invité Ecrit le: Dimanche 12 décembre 2004 à 18:45 Déconnecté(e)    
 
Ah mais je viens de me rendre compte que j'ai plein de b****l dans mon PC. (Je maîtrise encore mal SuSE). Je ne peux plus rien faire sur aucun paquetages, aucun RPM, j'ai des erreurs dès que j'y touche. Je vais réinstaller proprement Linux et je réessaye après.
    
./Post n°10   Marquer comme non lu.
squale92 Ecrit le: Dimanche 12 décembre 2004 à 18:49 Déconnecté(e)    Voir le profil de squale92 Envoyer un email à squale92 Visiter le site WEB de squale92 Envoyer un message privé à squale92  

si je peux me permettre...
Vu que tu es sous un système linux, pourquoi ne profites-tu pas du système des Makefiles ?
c'est franchement plus puissant qu'un script de ce genre, pour compiler !
tu dis de quoi chaque fichier dépend... et ça ne recompile à chaque fois que ce qu'il faut :)
(un peu comme fait l'IDE sous windows, sauf que ça ne recompile _vraiment_ que ce qu'il faut, si tu as bien réglé les dépendances)
Pascal MARTIN
http://www.squalenet.net
    
./Post n°11   Marquer comme non lu.
Kevin Kofler Ecrit le: Dimanche 12 décembre 2004 à 21:17 Déconnecté(e)    Voir le profil de Kevin Kofler Envoyer un email à Kevin Kofler Visiter le site WEB de Kevin Kofler Envoyer un message privé à Kevin Kofler  


AS :
Quoi que je fasse j'ai error: $TIGCC not set.

Et tu as bien les règlages qu'il faut dans ton /etc/bashrc? Regarde ce fichier avec un éditeur.
Membre de l'équipe de TIGCC: http://tigcc.ticalc.org
Mainteneur du portage Linux/Unix de TIGCC: http://tigcc.ticalc.org/linux/
Membre de l'équipe de CalcForge: http://www.calcforge.org:70/

Participez à la reprise de Ti-Gen!
    
  :: Index » Forum PC » Logiciels Linux/BSD » TIGCC (11 réponse(s))
Pages : 1/1     « [1] » »|

.Répondre à ce sujet
Les boutons de code
[B]old[I]talic[U]nderline[S]trikethrough[L]ine Flip Hori[Z]ontallyFlip [V]erticallySha[D]ow[G]low[S]poilerCode [G][C]ite
Bullet [L]istList Item [K] Link [H][E]mail[P]icture SmileysHelp
Couleurs :
Saisissez votre message
Activer les smileys
     

Forum de Ti-Gen v3.0 Copyright ©2004 by Geoffrey ANNEHEIM
Webmaster: Kevin KOFLER, Content Admins: list, Server Admins: Tyler CASSIDY and Kevin KOFLER, DNS Admin: squalyl
Page générée en 116.42ms avec 24 requetes