Créer un compte - S'identifier Accueil Archives FAQ Forum Statistiques Livre d'Or Samedi 24 Juin 2017 à 16:03:08

Questions/réponses

Ma calculatrice reste bloquée sur un message "Press I to install product code" ou "Press I to install code" et ne répond plus à aucune commande. Que faire ?

La première chose à essayer est de la redémarrer normalement. Pour cela, il faut retirer une des 4 piles AAA et la remettre. Si le système d'exploitation AMS est en état de fonctionnement, cela fera redémarrer la calculatrice normalement.

Si en revanche, le redémarrage s'arrête sur le même écran, c'est que le système d'exploitation AMS a été corrompu. Il faut dans ce cas réenvoyer AMS depuis un ordinateur. Attention, le fichier de mise à jour à envoyer ne doit pas avoir été modifié (patché). En cas de doûte, il vaut mieux le récupérer directement sur le site de TI.

Les logiciels les plus fiables pour cela sont soit l'ancien logiciel TI-Graph Link, soit le OS Downloader livré avec TI-Connect, disponibles tous les deux sur le site de TI. TiLP peut aussi être utilisé, et c'est le seul choix pour Linux par exemple.

Et comme le dit le message, il ne faut pas oublier d'appuyer sur [I] (sur TI-89, [9] suffit, pas la peine d'appuyer sur [alpha]) juste avant de lancer l'envoi.

Aucun commentaire

Ajoutée par @RHJPP le Dimanche 11 Septembre 2005 à 16:08:23. (2788 lectures)

Comment connaître sa version de rom et de hardware ?

Pour une TI-89 ou une TI-92+, il suffit d'aller dans le Home, d'appuyer sur F1 (bien entendu il faut que le menu soit le menu standard et pas un menu Custom) et d'aller sur About (A).
La fenêtre qui s'affiche alors contient par exemple :

Pour une TI-89 HW1 rom 1.00 :

TI-89 <-- il s'agit d'une HW1 car rien n'est indiqué
Advanced Mathematics Software
Version 1.00, 07/27/1998 <-- indique que l'AMS installé est la version 1.00
Product ID: 03-0-0-2A

Pour une TI-92+ HW2 rom 1.05 :

TI-92 Plus Hardware Version 2.00 <-- indique qu'il s'agit d'une HW2
Advanced Mathematics Software
Version 1.05, 06/02/1999 <-- indique que l'AMS installé est la version 1.05
Product ID: 1-1-3-7D

Pour une 92 simple, il faut aller dans l'écran PrgmIO (allez dans le Home et appuyez sur F5), puis presser la combinaison de touches [<>] + [(] (diamond + ouvrir la parenthèse).
La fenêtre qui s'affiche alors contient par exemple:

Pour une TI-92 de base avec ROM 1.12i :

Copyright...
Copyright...
Copyright...
Version 1.12 05/08/96 <-- indique que la version du système d'exploitation est la 1.12

Aucun commentaire

Ajoutée par @RHJPP le Dimanche 11 Septembre 2005 à 16:09:44. (2779 lectures)

[Erreur] : "invalid relocation data in ASM program" ?

Cette erreur se produit lorsque vous essayez de lancer un programme compressé en « ppg » sur un AMS trop récent (2.07 ou plus).

Les programmes compressés en « ppg » sont en fait constitués d'un lanceur, de type « ASM », et du programme compressé de type « ppg ». Il vous suffit pour résoudre le problème d'aller télécharger la dernière version du lanceur (ttstart) sur le site des auteurs : http://tict.ticalc.org. Une version pour la TI-89 Titanium (et pour la TI-89 Titanium seulement, pour les TI-89, TI-92+ et Voyage 200, cf. le lien précédent) est disponible ici. Cf. aussi l'entrée spécifique aux TI-89 Titanium.

Attention, le lanceur que vous allez télécharger n'est pas spécifique à votre programme. Au lieu de lancer « ttstart() », il vous faudra lancer « ttstart("program") » si le fichier « ppg » s'appelle « programme ».

Aucun commentaire

Ajoutée par @RHJPP le Dimanche 11 Septembre 2005 à 16:16:24. (2693 lectures)

Comment faire pour changer la version de la ROM ?

ATTENTION : cette opération efface complètement la mémoire de la TI. Assurez-vous d'en avoir fait un Backup !!

Tout d'abord, vous devez télécharger une ROM sur le site officiel de TI ou prenez celle sur le CD ressource. Une fois le téléchargement fini, dézippez la ROM dans un répertoire. L'extension du fichier doit être quelque chose comme *.89U ou *9xu ou encore *.v2u. Ensuite, lancez le logiciel Ti OS Downloader de Ti Connect et laissez-vous guider. Vous pouvez aussi envoyer la ROM comme un simple fichier avec Ti Connect.

Aucun commentaire

Ajoutée par @RHJPP le Dimanche 11 Septembre 2005 à 16:23:35. (2720 lectures)

Où trouver les dernière rom ?

Regardez sur http://education.ti.com afin de télécharger le dernier OS.

Aucun commentaire

Ajoutée par @RHJPP le Dimanche 11 Septembre 2005 à 16:32:53. (2663 lectures)

Pourquoi lorsque je veux lancer un programme en ASM j'ai le message: "ASAP or exec string too long" (ou "Chaîne ASAP ou Exec trop longue" en français) ?

Si vous obtenez ce message, il y a des chances que votre programme en assembleur ait besoin d'un kernel. Tout d'abord vous devez donc en installer un, il est conseillé d'utiliser PreOS (DoorsOS, Unios et, encore pire, PlusShell sont complètement dépassés).
Il est recommandé de télécharger et d'installer HW3Patch même sans un Hardware 3.

Vous devez aussi mettre sur votre calculatrice stdlib qui se trouve dans le paquetage de PreOS et ensuite l'archiver. Il est inutile de mettre sur sa calculatrice les librairies communes telles que ZipLib ou encore GraphLib, elles sont toutes incluses dans le fichier stdlib, ainsi un jeu demandant une librairie ira la chercher dans le fichier stdlib.

Aucun commentaire

Ajoutée par @RHJPP le Dimanche 11 Septembre 2005 à 16:38:38. (2755 lectures)

Que faire si la TI se bloque ou que rien ne s'affiche à l'écran ?

Si vous ne voyez rien à l'écran, vérifiez le contraste en appuyant sur [<>] + [+] ([<>] : Diamond, le losange vert) et vérifiez les piles !

Si vous utilisez un programme en TI-Basic, de vérifier en bas à droite de l'écran que vous n'êtes pas sur une pause. Il suffit si c'est le cas d'appuyer sur [ENTER]. Ensuite, si la calculatrice affiche « busy », et n'en démord pas, essayez [on], pour arrêter le programme en cours.

Si c'est plus sérieux, voici plusieurs possibilités à essayer, mais qui effacent la mémoire vive :

1) essayez les combinaisons de touche suivantes, en maintenant les touches appuyées toutes ensemble 3 secondes :
TI92, 92+ et V200 : [2nd]+[LOCK]+[On] (lock : la main en haut à gauche)
TI89 : [2nd]+[Gauche]+[Droite]+[On]

2) si ça ne marche pas, essayez de retirer une pile, d'appuyer plusieurs fois sur [ON], puis de remettre la pile

3) si ça ne marche pas non plus, la méthode suivante est plus brutale (efface tout, y compris mémoire archive et FlashApps !), mais MARCHE TRES SOUVENT :
Tous modèles : sortir une pile. La remette en place pendant que vous maintenez enfoncées les touches [(-)] et [)]. Relâcher ces touches au bout de 3 secondes.

4) sortir une pile, et en la remettant, laisser appuyé sur [(].

5) retirez toutes les piles de la calculatrice, y compris celle de sauvegarde, puis remettez-les en place après 2 minutes.

6) vous pouvez essayer de sortir le module (si vous en avez un - c'est le cas sur les TI-92+ HW1 seulement) mais faites attention aux connecteurs ! (le module c'est la boîte noire à côté de la pile de sauvegarde)

7) essayez d'appuyer sur [ON] quand vous remettez la dernière pile, ou alors [APPS].

8 ) une méthode qui marche presque à tous les coups : flasher la calculatrice depuis l'ordinateur. Mais pour cela bien sûr il faut que votre calculatrice soit flashable. Autrement dit, ça ne marche pas sur 92 et 92II.

Si aucune de ces méthodes ne fonctionne, il n'y a plus que le sav (service après-vente).

Aucun commentaire

Ajoutée par @RHJPP le Dimanche 11 Septembre 2005 à 16:43:49. (2457 lectures)

Qu'est-ce que le système d'exploitation/l'Advanced Mathematic Software (AMS), les rom 1.00, 1.01, 1.05, 2.01, 2.02, 2.03, 2.04, 2.05, 2.08, 2.09, 3.00, 3.01 et 3.10 ?

Le système d'exploitation est l'équivalent de Windows sur TI. L'Advanced Mathematic Software (AMS) est un terme mal définit, car servant à désigner à la fois le système d'exploitation et le logiciel de math.
Sur les 92 simples et les 92 II il n'est pas possible de le mettre à jour et il en existe beaucoup de versions qui n'apportent pas ou peu de changements visibles (corrections de bugs...).
Sur les 89, 92+, et V200 il est possible de le mettre à jour en téléchargeant la dernière version sur le site officiel. Pour les autres versions, voyez ici.
Pour la TI-89, les versions existantes sont :
la première : 1.00
la suivante : 1.05 dont les modifications sont nécessaires aux HW2 (une HW2 ne peut fonctionner avec l'AMS 1.00) et qui posait quelques problèmes avec les programmes en assembleur, problèmes plus ou moins résolus grâce à ROM Patch
les versions 2.01 et 2.02 qui n'ont jamais été disponibles sur le site de TI et qui sont à bannir (ceux qui les possèdent devraient installer une plus récente sans hésiter)
la version 2.03 qui permet l'accès à toute la mémoire archive et qui donne aussi la possibilité de récupérer cette mémoire archive après un plantage. Elle empêche l'exécution des programmes assembleur de plus de 8 ko, mais cette limite est brisée par les kernels depuis longtemps.
La version 2.04 qui n'apporte rien à part des incompatibilités. La limite passe de 8 à 24 ko, mais c'est sans importance puisqu’elle est totalement brisée par les kernels et hw2patch.
La version 2.05 est la plus stable : c'est avec elle que vous avez le moins de risque de perdre des fichiers archivés. Les versions 2.04 ou 2.05 sont nécessaires pour faire fonctionner les programmes en assembleur créés grâce au SDK de TI, ainsi que pour pouvoir installer certaines flash-apps.

La version 2.07 seulement sur V200.
La version 2.08 qui utilise enfin une partie hardware des TI HW2 qui est le RTS s'occupant de gérer l'horloge, Apps Deskop (mini environnement avec icônes) et ajout de quelques fonctions trigonométriques sans réelle utilité.

La version 2.09, support parfait d'un nouveau protocole de liaison de haut niveau et de TI-Navigator (2.07 et 2.08 l'ont, mais a priori il est incomplet).

Il faut savoir que sur TI89, la version 2.08 et la version 2.09 diminuent de 64 Ko la mémoire Flash, mais bizarrement on ne retrouve pas ce problème sur TI92+ et V200.

Les versions 3.**, ne sont compatible qu'avec les 89 Titanium et V200, la 3.10 ajoute la possibilité d'utiliser les Grades et quelques nouvelles fonctions.

Pour la 92+/V200, c'est pareil si ce n'est qu'il existe aussi l'AMS 1.01.
On utilise la notation 1.0x pour parler à la fois des AMS 1.00, 1.01 et 1.05, et 2.0x pour les AMS 2.01, 2.02, 2.03, 2.04, 2.05, 2.07, 2.08 et 2.09.

A noté qu'il existe aussi PedroM, un système d'exploitation totalement libre (dont les sources sont disponibles), il a l'avantage de proposer presque la totalité de la mémoire, ce système d'exploitation est assez simpliste dans la mesure où tout ce fait par lignes de commandes et ne possédant pas de fonctions mathématiques avancées. De plus PedroM n'est pas 100% compatible avec les programmes réalisés pour l'AMS, il manque certaines ROM_CALLS... En tout cas, ceci encourage les programmeurs à adopter PedroM.

Aucun commentaire

Ajoutée par @RHJPP le Dimanche 11 Septembre 2005 à 16:49:04. (2387 lectures)

Soumettre une question/réponse

Vous trouvez la catégorie suivante incomplète et vous désirez ajouter une question avec sa réponse correspondante.
Il vous est possible de complèter cette catégorie. Pour cela veuillez cliquer sur le bouton ci-dessous.

Ver:1.0 moved on CalcForge.org (2013-01-26) Copyright ©2005 By Geoffrey ANNEHEIM & Frédéric BOUR
Webmaster: Kevin KOFLER, Content Admins: list, Server Admins: Tyler CASSIDY and Kevin KOFLER, DNS Admin: squalyl
Page générée en 652.59 ms avec 15 requêtes.

Graphic theme: Geoffrey ANNEHEIM